MSD-7al-3 problems?

Page 1 of 2 1, 2  Next

Go down

MSD-7al-3 problems?

Post  airford1 on August 28th 2011, 7:55 pm

Engine has a mid rpm range miss so I check the timing and it's at 22', but only advances to 32'. Tried to reset initial timing back to 14' and the engine doesnt want to idle. I have sent this MSD box back before for the timing going crazy. what else could it be? Here we go , coil, dist, dist gear, bad mechanical advance, plugs/ cap and rotor,,,,,,,,,,,,,,,,,,,,,,
avatar
airford1

Posts : 133
Join date : 2009-10-15

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  BigDave65 on August 28th 2011, 9:16 pm

Do you have zero chips in the timing retards or have all the retard terminals grounded?

What distributor are you using?
avatar
BigDave65

Posts : 557
Join date : 2009-08-12
Age : 52
Location : Cliffside, NC

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  airford1 on August 29th 2011, 7:39 am

Yes zero chip in all timing retards and I am running a MSD pro billet magnetic trigger dist. Pretty simple. It is starting to act like the rev limiter is coming on.
avatar
airford1

Posts : 133
Join date : 2009-10-15

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  jbozzelle on August 29th 2011, 9:31 am

Have you changed out the rev limiter chip? They've been known to go bad before.

jbozzelle

Posts : 3537
Join date : 2009-08-10
Age : 44
Location : New Orleans

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  cool40 on August 29th 2011, 9:29 pm

jbozzelle wrote:Have you changed out the rev limiter chip? They've been known to go bad before.
mine did this year and Blake had one also go bad about the same time. if your timing is moving around and you rule out the diz,check your endplay on your cam. fords dont often have the issue like a chevy with the roller and cam button B/S.
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7135
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  airford1 on August 29th 2011, 10:13 pm

I acts like the rev limiter is coming in . I had the same problem when it was new and sent it back to MSD, they replaced a resistor board and sent it back. I got about 30 passes on it and it's starting to do the same thing.I will swap the box out and if its the box I'm really pissed.
avatar
airford1

Posts : 133
Join date : 2009-10-15

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  cool40 on August 29th 2011, 10:25 pm

i've been told the 3box was a pos,but i never had one.
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7135
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  psfracer on August 30th 2011, 10:52 am

I had problems with my 7AL3, changed out to the 7AL2 Plus and haven't had a problem since. My timing was moving around also, and I had zero chips on all for retards as well.
avatar
psfracer

Posts : 774
Join date : 2010-10-22
Location : Valencia, CA

View user profile http://www.psfracer.com

Back to top Go down

Re: MSD-7al-3 problems?

Post  56Tbird on August 30th 2011, 11:23 am

My 7AL3 is back at MSD right now ,for the 3rd time in the last 18 months!! I'm not real pleased with it at ALL. $169 last trip to fix it. At least this time it just completely quit after 2 passes of of clicking on and off at full throttle. Hopefully it didn't lift a head gasket or something worse this time!! It may have to find a new home Evil or Very Mad
avatar
56Tbird
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 5255
Join date : 2008-12-02
Age : 59
Location : Hawesville,Ky.

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  56Tbird on August 30th 2011, 12:06 pm

I just talked to MSD and they're going to send me a different 7AL3 since mine has been back 3 times in the last 18 months. I hope it's better than the last one!!
avatar
56Tbird
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 5255
Join date : 2008-12-02
Age : 59
Location : Hawesville,Ky.

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  psfracer on August 30th 2011, 12:31 pm

I would have them send you an 7AL2 Plus instead, seriously, unless you need the features of the 7AL3.
avatar
psfracer

Posts : 774
Join date : 2010-10-22
Location : Valencia, CA

View user profile http://www.psfracer.com

Back to top Go down

Re: MSD-7al-3 problems?

Post  BigDave65 on August 30th 2011, 4:20 pm

I know some have had issues with the 7AL-3's. but I've had one since my car was new in 1998 and (knock on wood) I haven't had the first issue with it. I guess it's cause I bought a used box out of a P/S truck to keep for a spare. I've tried blaming the box for troubles a few times but it's never caused any.
avatar
BigDave65

Posts : 557
Join date : 2009-08-12
Age : 52
Location : Cliffside, NC

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  maverick on August 30th 2011, 6:52 pm

A friend and I chased 7AL3 gremlins after switching from 6AL and 7AL2 boxes. After the boxes made repeated trips back to Texas for repairs, (MSD kept saying they were OK when they received them.) we started looking at other stuff. Suspect We found that we had to readjust rotor phase in order to make the car run right.
That is to say that when we swapped a 7AL3 into a good running car (removing either a 6AL or a 7AL3) the rotor phase had to be changed Question in order to get the car down the track. No, I can't explain it, either, but...... Rolling Eyes

Anyway, since yours was running OK before, then developed the problem....I doubt that's your trouble, but I thought you guys might wanna know.
avatar
maverick
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 3051
Join date : 2009-08-06
Age : 66

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  Lem Evans on August 30th 2011, 7:02 pm

The 7AL-2 Plus is a very good ignition.........if a guy needs more it looks like jumping to 7 Digital is the way to go.

Lem Evans

Posts : 7043
Join date : 2008-12-03
Location : Livermore , Ky

View user profile http://bfevansraceparts.com

Back to top Go down

Re: MSD-7al-3 problems?

Post  airford1 on August 30th 2011, 7:25 pm

cool40 wrote:i've been told the 3box was a pos,but i never had one.
So far I would have to agree. I is a shame to have a back up box just to know you can go racing for the weekend.
avatar
airford1

Posts : 133
Join date : 2009-10-15

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  cool40 on August 30th 2011, 9:38 pm

i still run the 7al2 i bought new back in the mid 90's and it works every time.
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7135
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  bbf-falcon on August 31st 2011, 11:28 pm

cool40 wrote:i still run the 7al2 i bought new back in the mid 90's and it works every time.
X2,and I have another for a backup,so mine should last forever Laughing

bbf-falcon

Posts : 8992
Join date : 2008-12-03
Location : Jackson, Ohio

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  airford1 on September 3rd 2011, 9:13 am

Let me be the first to say,,, MY BAD, the MSD 7al3 wasn't the problem. I had .035 end l play in my dist., and 3 plug wires with triple the OHM's reading. I will still keep my eye on the box because it a character you cannot leave home alone. We be drag racin again.
avatar
airford1

Posts : 133
Join date : 2009-10-15

View user profile

Back to top Go down

u figure out issue

Post  bbfdragster on September 19th 2012, 4:05 pm

I've been struggling to get my 608 bbf alcohol motor to go past 5500 rpm...check alcohol system ...timing at 32-36....
Don't pop or bang...starts good...idles good...just no top end...I've checked bout everything ..
Msd replaced a start retard board n Saussure its good to go...
also tried different chips.
This is my first alcohol motor n am struggling.

Thanks for ur help
Jason

bbfdragster

Posts : 121
Join date : 2011-10-28
Age : 38
Location : crete nebraksa

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  airford1 on September 19th 2012, 6:46 pm

bbf drag I would start a new thread. My problem was not the MSD 7 box and it turned out to be the crank shaft was .0008 smaller than the timing gear which made my timing move around. I use the timing retard to start and goto 30' after it starts. When I get to 3000rpm the timing moves back to 29' and I am living with that.
avatar
airford1

Posts : 133
Join date : 2009-10-15

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  richter69 on September 19th 2012, 7:18 pm

bbfdragster wrote:I've been struggling to get my 608 bbf alcohol motor to go past 5500 rpm...check alcohol system ...timing at 32-36....
Don't pop or bang...starts good...idles good...just no top end...I've checked bout everything ..
Msd replaced a start retard board n Saussure its good to go...
also tried different chips.
This is my first alcohol motor n am struggling.

Thanks for ur help
Jason


sounds fat fat fat........ what pump, nozzel etc? seems we've discussed it before.
avatar
richter69

Posts : 13645
Join date : 2008-12-02
Age : 47
Location : In the winners circle

View user profile

Back to top Go down

Injection info

Post  bbfdragster on September 19th 2012, 7:24 pm

Possible...been on this problem for couple years...n this year I had to redo wife's kitchen.
80-a1...7.5 gal....40 nozzle ....30% leak down on barrel valve...
n yes plugs r wet When I get back...
Boutght high speed bypass but haven't installed yet...
almost ready to go back to carbs.
Thanks for ur help guys.
Jason

bbfdragster

Posts : 121
Join date : 2011-10-28
Age : 38
Location : crete nebraksa

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  cool40 on September 19th 2012, 8:48 pm

bbfdragster wrote:Possible...been on this problem for couple years...n this year I had to redo wife's kitchen.
80-a1...7.5 gal....40 nozzle ....30% leak down on barrel valve...
n yes plugs r wet When I get back...
Boutght high speed bypass but haven't installed yet...
almost ready to go back to carbs.
Thanks for ur help guys.
Jason
nozzles are big,IMO.what main pill? whats the oil look like? if its fat it'll milk the oil.go here... http://fuelinjectionenterprises.com/ and do the user name etc etc,it's a free site,and check out the tuneup calculator.i've used it and its very close as long as the info you put in is right.my 526 likes less timing,28-30*,just a thought. Very Happy
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7135
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  460 lincoln on September 23rd 2012, 4:22 am

I have a 7al-2 msd box on my car and it has been a great box no problems.

460 lincoln

Posts : 2
Join date : 2010-10-29

View user profile

Back to top Go down

Re: MSD-7al-3 problems?

Post  maverick on April 17th 2014, 9:30 am

Update. Friends and I now have five MSD 7AL3 boxes working flawlessly. It's not a POS, but does require a couple of different setup details. You can't just plug one in place of a different box and run. We love ours.
avatar
maverick
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 3051
Join date : 2009-08-06
Age : 66

View user profile

Back to top Go down

Page 1 of 2 1, 2  Next

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum