I need advice on my ignition

Go down

I need advice on my ignition

Post  bigdaddy198 on March 26th 2012, 10:28 pm

I have a 460 in a 82 mustang i am in the process of wiring it up i had the car running on a temporary toggle switch to my msd box i have the dist hooked up to the purple and green wire with the correct harness when i flip on the toggle switch and hit the pushbutton for the starter it will turn over but the only time it fires up is just as you let off the pushbutton its like its not throwing spark until you let off the starter button i am gonna pull all the wires outthat came from the steering column as all i want to have is my switch panel in my fabricated dash to switch on ignition then my starter button and fuel pump on its own switch my fan has its switch andi want a extra switch for a fan inside the car its strictly for the trackbut i am wondering if i need to wire up another power source to the coil i just got adifferent 6al box and i will put it in this weekendjust cant figure out why it dosent fire up until you let off the starter button Suspect Suspect

bigdaddy198

Posts : 31
Join date : 2012-03-04

View user profile

Back to top Go down

Help i need advice

Post  bigdaddy198 on March 27th 2012, 2:15 pm

I was half asleep when i first tried to explain here is the deal i got this 82 mustang it already had the 460 and c6 in it and had been test drove but when i got itthe guy who built it took the msd box and the coil also he had wired up a toggle switch to control turning on the ignition a starterbutton and wired up the fuel pump on a toggle as well as the fan to a toggle ok i got a msd 6a box and a coil i hooked up everything as it should beas far as the msd box i ran the coil wires as they should and i got the adapter that hooks up the distributor to the violet and green wire here is the problem when i turn on the ignition toggle switch and hit the starterbutton it turns over great with the fuel pump on its getting fuel but when it is turning over its not firing up while the starter button is pushed the second you let off the starterbutton it fires up i got the msd 6a used could it be that its not putting any power to the coil until i let off the button i have had this car started about 20 times but it never actually fires until your letting off the starter button will it hurt to run another power wire to the coil when i try to fire it i just got a msd6al box from my buddy and when i get home this weekend i will wire it up and see if maybe the other box was bad any other ideas!!!!

bigdaddy198

Posts : 31
Join date : 2012-03-04

View user profile

Back to top Go down

Re: I need advice on my ignition

Post  96Mustang460cid on March 27th 2012, 5:02 pm

Some wires have 12+ volts:

-- All the time. Even if the key is off.
-- When the key is in the "on" position, but not while the key is in the "cranking" position.
-- When the key is in the "on" or "crank" position
-- Others maybe???

Is the wire that's going through the switch and to the MSD have 12+ while cranking? Or just while the key is in the "on" position? It sounds like it only has power when the key is in the "on" position.

Have a good day!
Michael
avatar
96Mustang460cid

Posts : 154
Join date : 2009-07-11
Location : Tulsa, OK

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum