C6 trans problem

Go down

C6 trans problem Empty C6 trans problem

Post  bigunitmudracing on August 8th 2012, 9:49 pm

I have a C6 in my mud truck. when i put it in second gear it stops the truck like you just put the brakes on ... first and third are fine.
bigunitmudracing
bigunitmudracing

Posts : 159
Join date : 2010-12-12
Location : hurley, wi

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  bigunitmudracing on August 8th 2012, 9:58 pm

i have a tci manual valve body and a code R piece in it.

Can the valve body cause this?
bigunitmudracing
bigunitmudracing

Posts : 159
Join date : 2010-12-12
Location : hurley, wi

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  whitefield on August 8th 2012, 10:08 pm

Hydraulic system leakage (V.B.) spring in servo broken, band adjustment, clutches burned up . Check condition of fluid and see if it has any gray or silver material in it , also look for brown or black material in it.
whitefield
whitefield

Posts : 2230
Join date : 2009-08-23
Age : 51

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  Frank Merkl on August 8th 2012, 10:20 pm

VB or servo will cause this , does the servo piston move free in the bore ? did you leave the oring off the small piston and plug the servo vent?
Frank
Frank Merkl
Frank Merkl

Posts : 1507
Join date : 2008-12-17
Age : 63
Location : Brooks ,Alberta ,Canada

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  bigunitmudracing on August 8th 2012, 11:14 pm

the servo ?? on the side. it was a kit and i haven't tore it apart but it was new a year ago...

the valve body i am taking out tommorow and what should i look for.??
bigunitmudracing
bigunitmudracing

Posts : 159
Join date : 2010-12-12
Location : hurley, wi

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  bigunitmudracing on August 9th 2012, 12:13 pm

at wide open throttle in second gear i had smoke coming into the cab from off the transmission...
bigunitmudracing
bigunitmudracing

Posts : 159
Join date : 2010-12-12
Location : hurley, wi

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  whitefield on August 9th 2012, 12:17 pm

Frank Merkl wrote:VB or servo will cause this , does the servo piston move free in the bore ? did you leave the oring off the small piston and plug the servo vent?
Frank

Check what Frank posted and then what I posted . Sounds like its got to come apart!
whitefield
whitefield

Posts : 2230
Join date : 2009-08-23
Age : 51

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  bigunitmudracing on August 12th 2012, 1:02 am

something is broke in the trans.. after more review, i have rev. and first.. thats it. pulled apart the 2nd gear servo perfect shape and pulled apart the valve body.. excellent shape... so now its getting pulled out. tommorow
bigunitmudracing
bigunitmudracing

Posts : 159
Join date : 2010-12-12
Location : hurley, wi

Back to top Go down

C6 trans problem Empty Re: C6 trans problem

Post  crittersf1 on August 12th 2012, 7:57 am

Clutches are welded together.
crittersf1
crittersf1

Posts : 521
Join date : 2009-10-28

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum