power glide problems, help

Go down

power glide problems, help  Empty power glide problems, help

Post  10SHOTS on January 14th 2013, 11:00 am

i built a powerglide with a jw case ans bell, 1.8 bte planatarys, trans king front pump, 8 clutch drum,trans king t-brake valve body, new ptc converter, kevlar band,
I started the engine up and let warm up, pulled it into gear on the lift, wheels tuned as should ,let it spin for about 5 minutes, ,stop the wheels, got on the t-brake and hit the gas, converter flashed to 5500 , SO i cranked it up again, tryed it again, trans brake locks but now the tack will not stop, hit the gas a goes upto 7500 fairly easy, hmm , let me check the linkage, alls good, so i try again, same thing, goes up hits the engine rev limiter, but the wheels are not turning, it sounds like theres a drag on the engine when reving , it not just free spooling, does anyone have an idea of whats going on, thanks
10SHOTS
10SHOTS

Posts : 587
Join date : 2010-11-26
Age : 43
Location : Brookhaven MS 39601

View user profile

Back to top Go down

power glide problems, help  Empty Re: power glide problems, help

Post  ustahava67 on January 14th 2013, 11:12 am

sounds like you may have wiped your converter
ustahava67
ustahava67

Posts : 53
Join date : 2009-11-30
Age : 57
Location : Caldwell, Idaho USA

View user profile

Back to top Go down

power glide problems, help  Empty Re: power glide problems, help

Post  10SHOTS on January 14th 2013, 11:36 am

converter is spragless, not sur what in the converter would break. ptc told me without the sprag its never going to break.but i dont know.
10SHOTS
10SHOTS

Posts : 587
Join date : 2010-11-26
Age : 43
Location : Brookhaven MS 39601

View user profile

Back to top Go down

power glide problems, help  Empty Re: power glide problems, help

Post  David Cole on January 14th 2013, 12:22 pm

Put a gauge on the servo port and check the pressure with it running.

You could have:

Broken converter, even though no sprag there is still plenty of stuff to break.
or
broken pump gears
or
stator tube broke loose and spun in the pump, blocking fluid flow

Have you tried it in high gear just to see if the wheels turn? If the wheels turn in high then a broken band strut, strut adjustment bolt or the band strut slipped out of place.

If all that checks out...pull the pan and check the internal linkage...the rooster comb (cracked or broken and spinning on the shaft) or the manual valve out of position.
David Cole
David Cole
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 851
Join date : 2009-08-06
Location : Jasper, Al

View user profile http://my.att.net/p/s/community.dll?ep=16&groupid=66449&

Back to top Go down

power glide problems, help  Empty Re: power glide problems, help

Post  10SHOTS on January 16th 2013, 10:46 am

update, found front pump gasket blowed out , jw said they sell a special gasket that they have seen problems, so if any of you guys have a jw case and bell, if your rebuilding it, call jw for a gasket , might save you some time and head aches
10SHOTS
10SHOTS

Posts : 587
Join date : 2010-11-26
Age : 43
Location : Brookhaven MS 39601

View user profile

Back to top Go down

power glide problems, help  Empty Re: power glide problems, help

Post  IDT-572 on January 16th 2013, 2:54 pm

10SHOTS wrote:update, found front pump gasket blowed out , jw said they sell a special gasket that they have seen problems, so if any of you guys have a jw case and bell, if your rebuilding it, call jw for a gasket , might save you some time and head aches

PTC told me that Jw had machined some cases wrong where the bell bolts to the housing. The bell touches the housing before the second step (where the gasket rides) comes together to the pump, and not clamping the gasket.
IDT-572
IDT-572
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 4624
Join date : 2008-12-02
Age : 58
Location : Shelbyville Tn.

View user profile

Back to top Go down

power glide problems, help  Empty Re: power glide problems, help

Post  10SHOTS on January 16th 2013, 3:57 pm

i will check it , thanks
10SHOTS
10SHOTS

Posts : 587
Join date : 2010-11-26
Age : 43
Location : Brookhaven MS 39601

View user profile

Back to top Go down

power glide problems, help  Empty Re: power glide problems, help

Post  10SHOTS on January 18th 2013, 11:03 am

IDT-572 wrote:
10SHOTS wrote:update, found front pump gasket blowed out , jw said they sell a special gasket that they have seen problems, so if any of you guys have a jw case and bell, if your rebuilding it, call jw for a gasket , might save you some time and head aches

PTC told me that Jw had machined some cases wrong where the bell bolts to the housing. The bell touches the housing before the second step (where the gasket rides) comes together to the pump, and not clamping the gasket.

the bell does hit the case, i called jw. gave them the case # and the bell number. they said send the bell in and they will machine it .
im tired of climbing hills.
10SHOTS
10SHOTS

Posts : 587
Join date : 2010-11-26
Age : 43
Location : Brookhaven MS 39601

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum