Exhaust port issue p51 heads

Go down

Exhaust port issue p51 heads

Post  hotrod9 on May 26th 2013, 12:49 pm

Anybody have any issues with exhaust port leaking coolant on the p51 heads.
Thought it was a head gasket issue but I guess the exhaust valve was open and filled up #1 cyl. Can see water seeping into the exhaust port but can't see where it' coming from on the car, chamber is dry. Will pull head again and see whats up, this engine only has about 10 runs on it all new stuff. Heads have not been ported OTB.
Thanks
Ed

hotrod9

Posts : 30
Join date : 2009-12-20

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  richter69 on May 26th 2013, 1:06 pm

mine are ported and no issues, Id say that one has a porosity issue.
avatar
richter69

Posts : 13645
Join date : 2008-12-02
Age : 47
Location : In the winners circle

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  dfree383 on May 26th 2013, 1:21 pm

pressure test it, Fabio is probably right. happens every once in awhile.
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 13967
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  hotrod9 on May 26th 2013, 2:20 pm

Wouldn't porosity have shown up earlier or could it have worked loose and started leaking?
Thanks
Ed

hotrod9

Posts : 30
Join date : 2009-12-20

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  bbf-falcon on May 26th 2013, 4:35 pm

hotrod9 wrote:Wouldn't porosity have shown up earlier or could it have worked loose and started leaking?
Thanks
Ed

Yep

bbf-falcon

Posts : 8992
Join date : 2008-12-03
Location : Jackson, Ohio

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  Dave C. on May 26th 2013, 5:10 pm

Before u tear it down try pressurizing the system . scratch

Dave C.

Posts : 1268
Join date : 2013-03-23

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  hotrod9 on May 26th 2013, 6:52 pm

Just got the head off and it looks like it is leaking between the seat and the head. This leak doesn't need any pressure it is leaking on the bench with water poured in the passages. Someone barrowed my spring clamp AHHHHH so I can't take the valve out to be sure. There also looks like some moisture build up on the other 3 but this one the water puddles pretty fast.
Ed

hotrod9

Posts : 30
Join date : 2009-12-20

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  richter69 on May 26th 2013, 7:49 pm

at this point it dont matter, Id get in contact with whoever you got the heads from.
avatar
richter69

Posts : 13645
Join date : 2008-12-02
Age : 47
Location : In the winners circle

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  hotrod9 on May 26th 2013, 8:21 pm

Got the heads from Kaase, problem is I milled the head a bit to get 70cc chambers and drilled a oil return line in the back of the head.

hotrod9

Posts : 30
Join date : 2009-12-20

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  hienergy557 on May 26th 2013, 10:17 pm

Sounds like it would have leaked even if you hadn't milled & drilled the heads. So it shouldn't be a issue.
Also mine have been milled to 65cc and ported, no leaks.
Talk to Kaase.
avatar
hienergy557

Posts : 172
Join date : 2009-08-20
Age : 55
Location : Melbourne, Australia

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  chuck on May 27th 2013, 12:42 am

I know some one who had an issue with their head leaking, I think kaase made repairs on the head.[i]

chuck

Posts : 414
Join date : 2009-08-08

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  cool40 on May 27th 2013, 12:48 am

hienergy557 wrote:Sounds like it would have leaked even if you hadn't milled & drilled the heads. So it shouldn't be a issue.
Also mine have been milled to 65cc and ported, no leaks.
Talk to Kaase.
x2!
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7135
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  hotrod9 on May 27th 2013, 12:53 pm

Just pulled out the valve and found the leak. It is not around the seat it is some porosity which is good news, tig weld, pressure test and should be golden. I would really like to make the race this weekend. Had to withdraw from one and miss 1 points race allready. Thanks to all who have listened, it's just one of those things that happen.
Ed

hotrod9

Posts : 30
Join date : 2009-12-20

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  torino501 on May 28th 2013, 6:38 pm

wouldn't ya think these heads would get pressure tested before getting shipped?just part of a quality control before shipping...?

torino501

Posts : 366
Join date : 2013-05-08
Location : THE GREAT STATE OF TEXAS!!!

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  Bill Heard on May 29th 2013, 1:41 am

I quit using my P51 heads because I can't get rid of the moisture in the valve covers. Had them presser tested and didn't find anything. Don't know what to do with them.
avatar
Bill Heard

Posts : 88
Join date : 2011-04-10
Age : 73
Location : Portland Oregon

View user profile

Back to top Go down

Re: Exhaust port issue p51 heads

Post  dfree383 on May 29th 2013, 3:18 am

Bill Heard wrote:I quit using my P51 heads because I can't get rid of the moisture in the valve covers. Had them presser tested and didn't find anything. Don't know what to do with them.

Gas tank sealer or use the egg shell stuff.
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 13967
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum