Head ports look damaged, OK or bad?

Go down

Head ports look damaged, OK or bad?

Post  racinghabbit on August 14th 2013, 12:13 pm

I have a set of DOVE-C heads  max effort....

I took a head off the other day and noticed that on the to of 3 of the Exhaust ports there are small holes threw the casting.out by where the header bolts on.( about 3/4 of an inch in from where the header bolts on) I have no idea how long its been like this..  

WIll it hurt anything?
Is it bad?
It runs great...
avatar
racinghabbit

Posts : 484
Join date : 2011-07-12

View user profile

Back to top Go down

Re: Head ports look damaged, OK or bad?

Post  dfree383 on August 14th 2013, 12:45 pm

Is it just broke thru into the head bolt holes? That not an Issue.
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: Head ports look damaged, OK or bad?

Post  racinghabbit on August 14th 2013, 1:15 pm

its at the very top of the port... just threw the internal casting
avatar
racinghabbit

Posts : 484
Join date : 2011-07-12

View user profile

Back to top Go down

Re: Head ports look damaged, OK or bad?

Post  dfree383 on August 14th 2013, 1:31 pm

Sounds like a break thru into the thermactor port... not a big deal either.

You can shove a rod down the port from the end of the head if the hole bothers you or even braze them.
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: Head ports look damaged, OK or bad?

Post  racinghabbit on August 15th 2013, 2:57 pm

Good news then!! They don't bother me... LOL What a Face 
avatar
racinghabbit

Posts : 484
Join date : 2011-07-12

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum