Killed the 600

Go down

Killed the 600

Post  Frank Merkl on June 17th 2014, 2:23 am

Well we when out with what we thought was all are ducks in a row but , lady luck said "NO" 2nd pass we had a piston fail , tough to tell but looks like a pin boss failed and let the rod and pin run free, AND CHANGE holes ! tough to tell with all the carnage , the piston is in to small of pieces, Oh well the 632 is just about ready !!!

and we worked on it hard

checked and rechecked

need another A460 block anyone have one that porosity that needed 8 sleeves as a big nitrous motor needed to have sleeves put in to start !!
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on June 17th 2014, 2:27 am

that's the water jacket your seeing and I unbolted the rods as there were 2 in 1 hole , bearings were like new
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  70FB on June 17th 2014, 5:50 am

Damn I hate to see this.
avatar
70FB
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 820
Join date : 2012-07-28
Age : 44
Location : VA

View user profile

Back to top Go down

Re: Killed the 600

Post  bbf-falcon on June 17th 2014, 6:20 am

Shit happens,sometimes worse than others. Sad 

bbf-falcon

Posts : 8992
Join date : 2008-12-03
Location : Jackson, Ohio

View user profile

Back to top Go down

Re: Killed the 600

Post  dfree383 on June 17th 2014, 9:09 am

Shit.... it will buff out! cheers

It sucks, but it's a good reason to upgrade!
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: Killed the 600

Post  Lem Evans on June 17th 2014, 9:38 am

Any chance the wrist pin went 1st?

Lem Evans

Posts : 7098
Join date : 2008-12-03
Location : Livermore , Ky

View user profile http://bfevansraceparts.com

Back to top Go down

aries

Post  747JetMech on June 17th 2014, 12:30 pm

Whose pins were you running?
avatar
747JetMech

Posts : 254
Join date : 2009-08-07

View user profile

Back to top Go down

Re: Killed the 600

Post  schmitty on June 17th 2014, 1:20 pm

Yep looks just like what you described the other night.   Sad
avatar
schmitty

Posts : 4538
Join date : 2008-12-02
Age : 48
Location : Holdrege, NE

View user profile

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on June 17th 2014, 7:33 pm

the pins came with the pistons from Venoila ,their suppose to be a heavy wall tool steel pin ,172 grams , I'm thinking something happened to the pin boss and the pin did all the destruction as its shattered to shards . plumbing the 2 foggers on the intake for the 623 now
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  Lem Evans on June 17th 2014, 7:36 pm

Are they straight or tappered?

Lem Evans

Posts : 7098
Join date : 2008-12-03
Location : Livermore , Ky

View user profile http://bfevansraceparts.com

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on June 17th 2014, 7:38 pm

straight
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  Moodyblues on June 25th 2014, 5:14 pm

dang that sucks, happened to me in October, we a rod broke. Don't think I will run aluminum rods again
avatar
Moodyblues

Posts : 1162
Join date : 2009-08-19
Age : 58
Location : Jasper, TN

View user profile http://www.russhoodinsurance.com

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on June 26th 2014, 9:08 am

aluminium rods are the Only thing I run unless I Win the Lotto then it will be Titanium !!
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on July 15th 2014, 1:14 am

pics of the carnage




something a sleeve and JB weld can't fix!!
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on July 15th 2014, 2:19 am

looks to me as the piston vanished and we had a connecting rod going around at 9300 rpm with no piston cleaning house !!!
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  dfree383 on July 15th 2014, 9:16 am

So what failed first? Piston? Cylinder wall? valve? Rod?
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on July 15th 2014, 1:52 pm

if I only knew!!!
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on July 16th 2014, 3:02 pm

this was  piston
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  dfree383 on July 16th 2014, 3:21 pm

Looks to me either the piston or the cylinder wall went first.
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: Killed the 600

Post  Moodyblues on July 17th 2014, 9:46 pm

Looks exactly what happened to mine last October. Guy did a half track burnout and I was waiting on him to stage and felt a vibration in the shifter...........
avatar
Moodyblues

Posts : 1162
Join date : 2009-08-19
Age : 58
Location : Jasper, TN

View user profile http://www.russhoodinsurance.com

Back to top Go down

Re: Killed the 600

Post  Frank Merkl on July 17th 2014, 10:29 pm

This happened 1.06 into the 2nd pass on a fresh motor ,ie ; new rods and pistons !
Frank
avatar
Frank Merkl

Posts : 1420
Join date : 2008-12-17
Age : 62
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

Re: Killed the 600

Post  bbf-falcon on July 17th 2014, 11:35 pm

Frank Merkl wrote:This  happened 1.06 into the 2nd pass on a fresh motor ,ie ; new rods and pistons !
Frank

Who knows,it's the life of a racer/engine builder. In the end it's all speculation. Unless the obvious shows it's ugly head.

bbf-falcon

Posts : 8992
Join date : 2008-12-03
Location : Jackson, Ohio

View user profile

Back to top Go down

Re: Killed the 600

Post  cool40 on July 18th 2014, 12:35 am

dfree383 wrote:Looks to me either the piston or the cylinder wall went first.
x2...... pale 
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7152
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: Killed the 600

Post  DanH on July 18th 2014, 5:18 am

vote for the cylinder wall failed first.

DanH

Posts : 1081
Join date : 2009-08-06

View user profile

Back to top Go down

Re: Killed the 600

Post  Dark Horse of Apocalypse on July 18th 2014, 8:14 pm

Wow that's ugly like a Wart Hog in a Prom dress.
avatar
Dark Horse of Apocalypse

Posts : 171
Join date : 2014-07-08
Location : North Central Ohio

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum