Ignition problem

Go down

Ignition problem

Post  racinghabbit on July 28th 2014, 10:18 pm

Mud truck with all msd. been running perfect for 3 years... and all of a sudden it doesn't want to start... Crank for like 2 minutes and finally it will start... the only thing on in the truck is the msd... Tried a new coil and it started right up... 1 time.. now it back to the same thing.... No spark for a long crank and then all of a sudden it will have spark... During a pass on it the spark started cutting out.... I'm down to the pickup coil or msd 6al box... what idea's do you have?
avatar
racinghabbit

Posts : 484
Join date : 2011-07-12

View user profile

Back to top Go down

Re: Ignition problem

Post  whatbumper on July 28th 2014, 11:18 pm

I'd be willing to bet your msd box is starting to go bad.

whatbumper

Posts : 3020
Join date : 2009-11-11
Age : 38

View user profile

Back to top Go down

Re: Ignition problem

Post  lghting94 on July 29th 2014, 8:22 am

I would suggest removing, cleaning and reinstalling all the grounds you can on the truck. We had small issues over the years with my old mud truck dirt get everywhere as you well know. May still end up being the box and or module in the distributor.
avatar
lghting94

Posts : 762
Join date : 2008-12-16
Location : Vine Grove Kentucky

View user profile

Back to top Go down

Re: Ignition problem

Post  bbf-falcon on July 29th 2014, 9:22 am

lghting94 wrote:I would suggest removing, cleaning and reinstalling all the grounds you can on the truck.  We had small issues over the years with my old mud truck dirt get everywhere as you well know.  May still end up being the box and or module in the distributor.

X2. Connections could be getting corroded or loose.

bbf-falcon

Posts : 8992
Join date : 2008-12-03
Location : Jackson, Ohio

View user profile

Back to top Go down

Re: Ignition problem

Post  BRONCOBILLY7.5 on July 29th 2014, 11:36 am

Last time I had this problem it was the pick-up coil/stator in the dist. Replaced it with another MSD pickup and all has been good 4 years later.
avatar
BRONCOBILLY7.5

Posts : 44
Join date : 2009-08-12
Age : 52
Location : OK

View user profile

Back to top Go down

Re: Ignition problem

Post  bbf-falcon on July 29th 2014, 9:26 pm

The pickup's are the same as Duraspark.

bbf-falcon

Posts : 8992
Join date : 2008-12-03
Location : Jackson, Ohio

View user profile

Back to top Go down

Re: Ignition problem

Post  racinghabbit on July 30th 2014, 12:24 pm

Cleaned grounds and did the msd test on the box and coil... its working fine last nite again after i did this stuff..... .. Just don't want to miss a race because of this crap.... random no spark is a pain...
avatar
racinghabbit

Posts : 484
Join date : 2011-07-12

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum