C6 question

Go down

C6 question Empty C6 question

Post  slurm on October 29th 2014, 11:10 am

Bought a c6 from patc and have it behind a 545 63 galaxie street driven. The first one started slipping after a couple of weeks with burnt fluid. I sent it back got the transmission last week now slips in reverse feels like it is stuck in second even when manually shifting, fluid looks fine. Could this be a valve body issue? Any suggestions would be great.
slurm
slurm

Posts : 83
Join date : 2011-09-16
Age : 39
Location : north dakota

View user profile

Back to top Go down

C6 question Empty Re: C6 question

Post  Frank Merkl on October 29th 2014, 4:25 pm

Check the servo and see if it's stuck in the case , if not it's a vb problem
Frank
Frank Merkl
Frank Merkl

Posts : 1504
Join date : 2008-12-17
Age : 63
Location : Brooks ,Alberta ,Canada

View user profile

Back to top Go down

C6 question Empty Re: C6 question

Post  slurm on October 30th 2014, 1:32 pm

Thanks for the info. Got a new vb on its way.
slurm
slurm

Posts : 83
Join date : 2011-09-16
Age : 39
Location : north dakota

View user profile

Back to top Go down

C6 question Empty Re: C6 question

Post  Gregaust on October 31st 2014, 7:05 am

But did you check what Frank suggested ? Throwing new parts at it won't always fix it, need to check . Be also having a real good look at shifter adjustment .

Gregaust

Posts : 527
Join date : 2009-08-09

View user profile

Back to top Go down

C6 question Empty Re: C6 question

Post  slurm on October 31st 2014, 9:13 am

Yes i did servo was not stuck, however shifter adjustment i will have to check.
slurm
slurm

Posts : 83
Join date : 2011-09-16
Age : 39
Location : north dakota

View user profile

Back to top Go down

C6 question Empty Re: C6 question

Post  slurm on February 4th 2015, 12:03 am

update The case had a crack in it. Hits so hard bill clinton is jealous.
slurm
slurm

Posts : 83
Join date : 2011-09-16
Age : 39
Location : north dakota

View user profile

Back to top Go down

C6 question Empty Re: C6 question

Post  Gregaust on February 27th 2015, 5:34 am

Where was the crack out of curiosity ???? Question

Gregaust

Posts : 527
Join date : 2009-08-09

View user profile

Back to top Go down

C6 question Empty Re: C6 question

Post  slurm on March 29th 2015, 9:27 pm

They said crack was around midsection of main case. I figure it might had to do with the second gear apply servo.
slurm
slurm

Posts : 83
Join date : 2011-09-16
Age : 39
Location : north dakota

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum