something wrong? or is it!

Page 1 of 2 1, 2  Next

Go down

something wrong? or is it!

Post  nitrous.f on November 30th 2015, 2:45 pm

took my heads to a guy just to see what they would flow and man I was disappointed! int valve 2.350 ex valve 1.880 Shocked these look more like small block #'s to me!
ask what bore spacing did he used and he said 4.500. don't know the factory flow # but they have to be more than this!
I think out the box when they were new they did better than this!


int.28'' EX.28''
.100 -80 .100-70
.200-167 .200-127
.300-244 .300-169
.400-310 .400-197
.500-346 .500-221
.600-343 .600-236
.700-335 .700-249
.800-335 .800-255

seem like iam missing anywere from 70-100 cfm up to .800 lift! do seem right or did he not do something right in his flow work! let me know what you think! Evil or Very Mad
avatar
nitrous.f

Posts : 271
Join date : 2011-06-05

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  dfree383 on November 30th 2015, 3:44 pm

Which heads?

And what bench was he using?
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  nitrous.f on November 30th 2015, 4:05 pm

motorsport a460 heads! sf 600 flow beach:D
avatar
nitrous.f

Posts : 271
Join date : 2011-06-05

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  dfree383 on November 30th 2015, 4:55 pm

Definitely look low, but keep in mind the older Motorsport castings will not flow like the later TFS stuff.

I'd check and make sure he didn't give you the wrong sheet.
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  rmcomprandy on November 30th 2015, 6:12 pm

That is a little on the low side and more like what the B460 heads would flow but close to about right for an "out of the box" original A460 Motorsport head with no port work however, they were never available with a 2.350" intake valve from Ford.

rmcomprandy

Posts : 5091
Join date : 2008-12-02
Location : Roseville, Michigan

View user profile http://www.rmcompetition.com

Back to top Go down

Re: something wrong? or is it!

Post  nitrous.f on November 30th 2015, 7:35 pm

the guy I bought them from said he will text me the flow sheet he got with the heads, and said that they definitely flowed somewhere in the 390 on int and high 200's. will let you guys know when he text it to me tonite! Very Happy
avatar
nitrous.f

Posts : 271
Join date : 2011-06-05

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  cool40 on November 30th 2015, 9:52 pm

That's a little low but not much.mine did around 360 I think but with 2.3 valve. I didn't have any problem getting 425 out of them.
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7154
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  nitrous.f on November 30th 2015, 10:43 pm

ok guys the guy I bought the heads from contacted me and sent me the real #'s over to my phone! here they are
sorry int valve 2.300 ext 1.88
int                ext
.200-178      .200-134
.300-242       .300-174
.400-303       .400-214
.500-355       .500-244
.600-375        .600-260
.700-384        .700-273
.800-390         .800-280



superflow sf 600@28''  


they came  off of a 2000lb dragster with a 477 with these heads  going 8.20-8.30 in the heat  and 7.95 he said  in good air! don't remember the compression!
so with kind of hp power you guys think I can make on a 598 motor 13.1 comp  n/a and on a 350 shot of the good stuff! my car is 2750 wirh me in it! and thanks guys! Cool
avatar
nitrous.f

Posts : 271
Join date : 2011-06-05

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  dfree383 on November 30th 2015, 11:28 pm

Probably make about 850-900hp
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  nitrous.f on December 1st 2015, 9:08 am

these are unported a460 motorsport heads! now that I know they are virgin heads they will now got a port and polish job! shouldn't be hard to get them in the 400cfm range int and 300cfm on ext! Very Happy
avatar
nitrous.f

Posts : 271
Join date : 2011-06-05

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  whatbumper on December 1st 2015, 12:46 pm

My flow bench puts frowns on a lot of people's faces. I have a hard time believing an unported set of heads flowed anywhere near the upper 300 range with that casting.

whatbumper

Posts : 3020
Join date : 2009-11-11
Age : 38

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  yellowhorse7 on December 1st 2015, 3:39 pm

It's a good thing flow benches don't win races
avatar
yellowhorse7

Posts : 1382
Join date : 2009-11-16
Age : 92
Location : Polk County

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  whatbumper on December 1st 2015, 5:39 pm

yellowhorse7 wrote:It's a good thing flow benches don't win races

correct. but it does pay the bills. it's just a shame that some people inflate their numbers to make people happy.

whatbumper

Posts : 3020
Join date : 2009-11-11
Age : 38

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  Lem Evans on December 1st 2015, 5:43 pm

whatbumper wrote:My flow bench puts frowns on a lot of people's faces.  I have a hard time believing an unported  set of heads flowed anywhere near the upper 300 range with that casting.

Which bench do you have?

Lem Evans

Posts : 7099
Join date : 2008-12-03
Location : Livermore , Ky

View user profile http://bfevansraceparts.com

Back to top Go down

Re: something wrong? or is it!

Post  cool40 on December 1st 2015, 9:04 pm

Lem Evans wrote:
whatbumper wrote:My flow bench puts frowns on a lot of people's faces.  I have a hard time believing an unported  set of heads flowed anywhere near the upper 300 range with that casting.

Which bench do you have?
it sounds like a mourners bench Question jocolor
avatar
cool40
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 7154
Join date : 2009-08-31
Age : 47
Location : on the 1/8 mile dyno

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  nitrous.f on December 1st 2015, 9:25 pm

yellowhorse7 wrote:It's a good thing flow benches don't win races

you right about Very Happy that!
avatar
nitrous.f

Posts : 271
Join date : 2011-06-05

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  Lem Evans on December 1st 2015, 11:00 pm

yellowhorse7 wrote:It's a good thing flow benches don't win races

If a guy leaves late he is damn sure beat....is that what you are addressing?

Lem Evans

Posts : 7099
Join date : 2008-12-03
Location : Livermore , Ky

View user profile http://bfevansraceparts.com

Back to top Go down

Re: something wrong? or is it!

Post  jones on December 1st 2015, 11:35 pm

whatbumper wrote:My flow bench puts frowns on a lot of people's faces.  I have a hard time believing an unported  set of heads flowed anywhere near the upper 300 range with that casting.

Are you saying that you are the one that flowed the OP heads?

jones

Posts : 2212
Join date : 2008-12-02
Location : Philadelphia, MS.

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  whatbumper on December 2nd 2015, 12:03 am

jones wrote:
whatbumper wrote:My flow bench puts frowns on a lot of people's faces.  I have a hard time believing an unported  set of heads flowed anywhere near the upper 300 range with that casting.

Are you saying that you are the one that flowed the OP heads?

No, I've not touched his heads.  

Lem, I have a sf-1020 bench.

whatbumper

Posts : 3020
Join date : 2009-11-11
Age : 38

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  nitrous.f on December 2nd 2015, 10:45 am

ran the flow sheet #'s threw my desktop dyno  software and it made  942hp with 12.7.1  comp  843tq  598ci ,that's without the nos! with the nos  its talking about 1220hp  1280tq on 300 shot,which should get me were iam trying to get to,  in the 7 second zone! not really trying to brake in to the 1000hp zone on motor. just trying  leave enough quench for the nos, need a big tuning window! so making 1000hp+ would be nice its not the hole story for me as a dedicated nos car! 2750lb mustang! I have a induction solution fogger with a lot more spray to go! love you guys input! Very Happy
avatar
nitrous.f

Posts : 271
Join date : 2011-06-05

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  Lem Evans on December 2nd 2015, 11:40 am

whatbumper wrote:
yellowhorse7 wrote:It's a good thing flow benches don't win races

correct.   but it does pay the bills.  it's just a shame that some people inflate their numbers to make people happy.  

Jeff Jones of Washington, IN. has a 1020 and a 600 SF. They don't produce the same numbers.... the same room and operator. It's not always a case of someone fudging the numbers.

Lem Evans

Posts : 7099
Join date : 2008-12-03
Location : Livermore , Ky

View user profile http://bfevansraceparts.com

Back to top Go down

Re: something wrong? or is it!

Post  whatbumper on December 2nd 2015, 1:08 pm

Lem Evans wrote:
whatbumper wrote:
yellowhorse7 wrote:It's a good thing flow benches don't win races

correct.   but it does pay the bills.  it's just a shame that some people inflate their numbers to make people happy.  

Jeff Jones of Washington, IN. has a 1020 and a 600 SF. They don't produce the same numbers.... the same room and operator. It's not always a case of someone fudging the numbers.

I understand that but in this industry it seems the norm for guys to do that for some reason. Everyone is a head porter now right? LOL

If these really went 390 unported that's awesome.

whatbumper

Posts : 3020
Join date : 2009-11-11
Age : 38

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  dfree383 on December 2nd 2015, 2:03 pm

whatbumper wrote:
Lem Evans wrote:
whatbumper wrote:
yellowhorse7 wrote:It's a good thing flow benches don't win races

correct.   but it does pay the bills.  it's just a shame that some people inflate their numbers to make people happy.  

Jeff Jones of Washington, IN. has a 1020 and a 600 SF. They don't produce the same numbers.... the same room and operator. It's not always a case of someone fudging the numbers.

I understand that but in this industry it seems the norm for guys to do that for some reason.  Everyone is a head porter now right? LOL

If these really went 390 unported that's awesome.  

I had a ported set that went 445 on a sf600 and that same bench has tested a lot of other similar heads
avatar
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14124
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  yellowhorse7 on December 2nd 2015, 2:04 pm

Lem Evans wrote:
yellowhorse7 wrote:It's a good thing flow benches don't win races

If a guy leaves late he is damn sure beat....is that what you are addressing?

All I meant was that I've seen (we ALL have) heads that flow shit on a bench but still seem to make impressive power numbers real-time. And there plenty of head porters out there that inflate numbers to sell product and service. For example.....P51 heads lol
avatar
yellowhorse7

Posts : 1382
Join date : 2009-11-16
Age : 92
Location : Polk County

View user profile

Back to top Go down

Re: something wrong? or is it!

Post  Lem Evans on December 2nd 2015, 4:33 pm

What's interesting, relative to the power vs flow equation, is the effect of valve jobs & valve shapes while using the same port.

Sometimes there is a gain in flow and more power. Sometimes there is no more flow and more power and sometimes there is a little less flow and more power.

Maybe it's a wet flow deal or the package is more resistant to reversion or maybe both.

Lem Evans

Posts : 7099
Join date : 2008-12-03
Location : Livermore , Ky

View user profile http://bfevansraceparts.com

Back to top Go down

Page 1 of 2 1, 2  Next

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum