C6 Sluggish when cold

Go down

C6 Sluggish when cold Empty C6 Sluggish when cold

Post  Tore on November 17th 2019, 5:21 pm

I have a C6 in a 70 Torino and when its cold its sluggish shifting out of low into 2nd and 3rd. When its warm its ok. I pulled the pan and the filter is clean and the fluid is clean also. Can it be a valve body issue?
I also noticed this valve body has a little tag that has KB stamped in it. What do those letters designate? Also I have a valve body from another tranny that has a tag CJ stamped in it. Is this Cobra Jet valve body? Would this be an improvement over the KB stamped Valve body?
The servo is also an S servo.

Tks Tore
Tore
Tore

Posts : 837
Join date : 2009-08-19

Back to top Go down

C6 Sluggish when cold Empty Moderator

Post  Tore on November 17th 2019, 5:26 pm

I hit the wrong area to enter my info I am asking for. can you help.

Tks Tore
Tore
Tore

Posts : 837
Join date : 2009-08-19

Back to top Go down

C6 Sluggish when cold Empty Re: C6 Sluggish when cold

Post  Gregaust on November 18th 2019, 5:56 am

The S is a fairly small apply servo , ok for a mild engine but if you're making good power there are better .
That's not your issue though.
What is done to your current valvebody ? Most valvebodies are similar in stock form ..
Assuming auto shifts ? How did you set them modulator? How much preload is on the pin? Assuming you have a good full manifold vacuum source to the modulator ?

Gregaust

Posts : 531
Join date : 2009-08-09

Back to top Go down

C6 Sluggish when cold Empty Re: C6 Sluggish when cold

Post  Tore on November 18th 2019, 9:15 am

I have done absolutely nothing to the tranny. No modulator adjustment at all. Actually I don't know anything about the adjustment process at all.

Tore
Tore
Tore

Posts : 837
Join date : 2009-08-19

Back to top Go down

C6 Sluggish when cold Empty Re: C6 Sluggish when cold

Post  Gregaust on November 19th 2019, 5:07 am

You could try a modulator adjustment then , if it is adjustable there is a screw up the centre where the vacuum hose pushes on. Try backing the screw out 1 turn see if it changes anything.
Assuming the oil has been changed at some stage ?
Could also be a case of the trans being old and some pressure loss from hard seals ?? When drive is selected is there a delay with it going into gear ?

Gregaust

Posts : 531
Join date : 2009-08-09

Back to top Go down

C6 Sluggish when cold Empty Re: C6 Sluggish when cold

Post  Tore on November 19th 2019, 6:47 am

No delay while going into any gear manually.
Tore
Tore

Posts : 837
Join date : 2009-08-19

Back to top Go down

C6 Sluggish when cold Empty Re: C6 Sluggish when cold

Post  Tore on November 21st 2019, 7:37 am

I put some seal softener in and will see what happens.

Tks Tore
Tore
Tore

Posts : 837
Join date : 2009-08-19

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum