New to the Site

Go down

New to the Site Empty New to the Site

Post  mkopmani on May 26th 2012, 6:50 am

Hi guys, I'm new to the website. A few years ago I used to participate on the FE Forum and on the 385 Series website, but then they started limiting the number of people on there and if I'm right, asking for a fee to post. At any rate, I stopped going there.

I've recently found this site and it seems to have drawn a lot of those same folks who were on the others. Don't know if they are still in existance or not.

One question I have is what the method is for posting pictures. My profile shows that I'm unable to post anything. Do you have to post all pictures through a general posting site, or are you guys doing something different? If someone can let me know, I'd sure appreciate it. Thanks.

I've been building BBF's, Clevelands and FE's for several years, but also have been working with the new 6.2L Ford on the side. Right now I've got a 500ci Alan Root / C&C Boss 429 with Enderle injection that's in a round tube chassis '64 Galaxie that I've been working to put together the last 2 years. Car is almost ready for starting shakedown passes.

Some info on it:
4.600 bore, 3.72 Bryant, BME 500 rods, Ti valves, Jesel rockers, 16.2:1 Venolias, Mallory mag, Greg Davis intake, Barnes dry sump. I'm starting with a JW Glide, but will switch to a Lenco & AFT clutch I have once things are established.

mkopmani

Posts : 37
Join date : 2012-05-24
Location : Michigan

View user profile

Back to top Go down

New to the Site Empty Re: New to the Site

Post  dfree383 on May 26th 2012, 7:31 am

Open a Photobucket Account and Download your pictures there. www.photobucket.com

Then Copy and Paste the IMG links here.
dfree383
dfree383
BBF CONTRIBUTOR
BBF CONTRIBUTOR

Posts : 14240
Join date : 2009-07-09
Location : Home Wif Da Wife.....

View user profile

Back to top Go down

New to the Site Empty Thanks!

Post  mkopmani on May 26th 2012, 7:52 pm

Thanks for the help. I have to wait 7 days before I can post anything - I'm guessing for security reasons.
Mike

mkopmani

Posts : 37
Join date : 2012-05-24
Location : Michigan

View user profile

Back to top Go down

New to the Site Empty Re: New to the Site

Post  '65 T-BOLT on May 26th 2012, 8:33 pm

car sounds bad to the bone
'65 T-BOLT
'65 T-BOLT

Posts : 1464
Join date : 2009-08-28
Age : 48
Location : Hagerstown,Maryland

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum